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1 Introduction and Setup
Rulepacks are Java Archive (JAR) files that contain the files used by
SecureAssist to analyze source code against a set of rules and detect
vulnerabilities in real time as you code. Codiscope provides a default
rulepack. However, in many cases, an organization may wish to scan
for issues not included in the default Codiscope rulepacks (for
example, rules enforcing a company’s specific cryptography
standards). Using Rulepack Configurator, you can customize the
default rulepack to meet your unique needs. You can even create
your own rulepacks, save them, then import them into SecureAssist.

System and User Requirements
Developing rules requires an understanding of the SecureAssist rule
schema, a basic knowledge of regular expressions (regex,) and a
programming background. Developers of xml rules need knowledge
of XPath. Deciding what the rule itself entails (what code to flag, what
vulnerability the rule is for, user guidance) requires an understanding
of software security.

Opening Rulepack Configurator the First Time
A Java Development Kit (JDK) needs to be available to run Rulepack
Configurator. The Rulepack Configurator prompts for the JDK path
the first time it is opened.
1. Open Rulepack.exe. A dialog will prompt you to enter the JDK
path. (Rulepack Configurator prepopulates with the JDK path,
if JDK is available in the program files folder.)
2. Browse to the JDK path (if necessary) and click OK. The dialog
closes and Rulepack Configurator opens.
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3. Exit the program by choosing Exit from the File menu or
clicking the
. A popup will ask whether you want to
continue.
4. Click OK. A second dialog will ask whether you want to save
any new or extracted files in the archive.
5. Click Yes. The JDK path will now be saved, and you won’t be
prompted to enter it again.
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2 Rulepack Configurator
Quick Start
What are Rulepacks?
Rulepacks are Java Archive (JAR) files that contain the files used by
SecureAssist to analyze source code against a set of rules and detect
vulnerabilities in real time as you code. A rulepack contains filters,
guidance, propagators, rules, and sources that customize how and
which vulnerabilities are reported.
When you open a rulepack in Rulepack Configurator, you will see that
it consists of two folders: Default and Custom.


The Default folder is read-only and contains all the default
elements in the rulepack.



The Custom folder is where you can add or edit custom rules,
sources, propagators, filters, and guidances. The individual
custom settings you create in Custom will override the
corresponding settings in Default. The Custom folder tree is
empty until you add custom files to it.

To be usable, a rulepack should contain at least one rule, one filter,
and one guidance. These three elements reference one another.
Propagators and sources, conversely, do not reference any other
elements.
Item

Description

Rules

Instruct SecureAssist on what vulnerabilities to identify in your
code.
Linked to Filter by Rule ID.
Links to Guidance by Rule Standard (guidance filename).

Filters

Modify the way rules behave. Organize rules into categories,
determine which rules are visible in the editor window of the
IDE, and determine rules' severity levels. A rule must be added
to a filter and activated for SecureAssist to display the rule’s
results.
Custom rules that you create are disabled by default and must
be enabled via a filter.
Links to one or more rules by Rule ID.
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Item

Description

Guidances

Provide advice to a SecureAssist user about how to fix the
vulnerability. When code triggers a finding, guidance supplies
the developer with the language-specific information necessary
to understand and remediate the vulnerability.
Linked to in one or more rules by Rule Standard (guidance
filename).

Propagators

Track how taint travels through a system and describe
conditions on which taint is passed between objects.
Feeds information to the Call Chain in SecureAssist.

Sources

Inform SecureAssist where untrusted data can potentially enter
an application. When SecureAssist finds a source, it is marked
as such, and used to determine which lines of code are
insecure during taint flow analysis.
Feeds information to the Call Chain in SecureAssist.

Open and View an Existing
Rulepack
When you first open Rulepack Configurator, you’ll be confronted with
a blank screen. To populate it, follow these instructions.

 Open a Rulepack
1. From the File menu, choose Open Rulepack.
2. From the Open File dialog, browse to and select the desired
JAR file, then click Open. Rulepack Configurator displays the
selected rulepack in a folder tree.
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3. Browse the folders to see the different component files. The
Default folder contains the default files for the rulepack.
These files cannot be edited. To make changes, you can add
and edit files in the Custom folder.

 Open and View Files in a Rulepack
1. In an open rulepack, browse the navigation tree to locate the
desired file.
2. Double-click an individual file. The file opens in a tab in the
editing window.
3. To close the file, click the
editing window.

on the file’s tab at the top of the

Remember! Files in the Default folder will be read-only.

Customize a Rulepack
Your company may have rules you’d like to activate in SecureAssist
that don’t appear in the default rulepack. To do this, you can
customize the rulepack. There are two ways to customize a rulepack:
add new unique custom files OR revise default files by editing copies
of them.

Rulepack Settings
The settings for your rulepack appear in the settings.xml file at the
bottom of the navigation tree. To edit them, double-click the file to
display it in the editing window.
By default, the setting Custom filters have priority is selected. This
means that when the rulepack is run in SecureAssist, any default
rulepack files that you’ve customized will take precedence over the
default files.
The Filter Settings is where you can choose to activate or deactivate
any of the filters contained in the rulepack. By default, all custom
filters are activated.

Views
When you open a custom file in a rulepack, you can choose to view or
edit it in one of two views, which you select by clicking on the tabs on
the bottom of the editing window:
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Design. The Design tab presents the file's xml elements in a
collapsible, graphical hierarchy.
Source. The Source tab presents the file code for direct
editing.

The exception to this is guidance files. By default, a guidance file is
displayed in a graphical wizard. However, you can choose to view
guidance files using the Design and Source tabs by right-clicking the
file and choosing View Source from the popup menu. This will open
a second tab displaying the file in the format.

Working with Files

 Customize a Default Guidance File
Custom guidance files created this way will override the
rulepack’s default files.
1. In the navigation tree, right-click on either of the Guidances
folder and select Customize Default Guidance. A dialog lists
all the existing default guidance files.
2. Type the desired file name in the Select Guidance box OR
select the desired file from the list, then click OK. The file is
copied to the Custom Guidance folder with the same file
name as the default file. The new file is opened automatically
in the editing window.
3. If needed, resize the editing window so that the Overwrite
checkboxes to the right of the data entry fields are displayed.
4. Check Overwrite next to the sections you wish to change,
then make the desired changes to those sections. (Each
section is read-only until you click its Overwrite box.)
5. To revert a section to the original content from the default
guidance file, deselect Overwrite. Your edits will be
reversed, and the section contents will be restored.
6. Choose Save from the File menu.
7. To close the file, click the on the file’s tab.
Important! When you save a rulepack file, the changes will be
retained for that session only UNLESS you additionally choose
Save Rulepack from the File menu.
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 Customize a Default Filter, Propagator, Rule, or
Source File

Custom files created this way will override the rulepack’s default
files.
1. In the navigation tree, open the default file you wish to
customize.
2. Copy the contents of the default file, then close its tab.
3. Right-click on any of the Custom subfolders, select New, then
select the type of file you wish to create. A dialog prompts
you to enter a new name for the file you’re creating, plus any
other required fields for the file type.
4. Enter the same file name as the original default file.
Important! The file name must be identical in order to ensure
the custom file overrides the default file.
5. Enter values in any other fields, then click Create. The file is
created in the appropriate folder and opened in a tab in the
editing window.
6. Enter data in fields as desired.
7. Choose Save from the File menu.
8. To close the file, click the on the file’s tab.

 Create a New Custom File
Custom files created this way will run in addition to the rulepack’s
default files.
1. In the navigation tree, right-click on any of the Custom
subfolders, select New, then select the type of file you wish to
create. A dialog prompts you to enter a new name for the file
you’re creating, plus any other required fields for the file type.
2. Enter a unique file name. Important! If you want this custom
file to run in addition to the default files, it must have a
unique file name.
3. Enter values in the fields, then click Create. The file is created
in the appropriate folder and opened in a tab in the editing
window.
4. Enter data in fields as desired.
5. Choose Save from the File menu.
6. To close the file, click the on the file’s tab.
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 Validate a File
1. Right-click the desired file and select Validate from the
popup menu. Validation is run on the file. A popup will
confirm successful validation.
If validation fails, an error message will list any problems you
must resolve before validation can be successful.

 Preview Guidance
This feature allows you to view how your guidance page will
appear in SecureAssist.
1. Right-click the desired guidance file and select Preview from
the popup menu. A read-only tab opens in the editing
window, displaying the guidance as it will appear in
SecureAssist.
2. To close the preview, click the

on the tab.

 Rename a File
1. In the navigation tree, right-click the desired file and select
Rename. The File Rename dialog opens.
2. Edit the file name as desired and click Rename.

 Save Current File
1. To save the current file, choose Save from the File menu OR
press Ctrl+S.

 Save All Open Files
1. To save all open files in a rulepack, choose Save All from the
File menu OR press Ctrl+Shift+S.

 Delete a Custom File
Default files cannot be deleted.
1. In the navigation tree, right-click the desired file and select
Delete.
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Rulepacks

 Validate Rulepack
1. Right-click on the rulepack (the top folder) in the navigation
tree and select Validate Rulepack. Validation is run on the
entire rulepack. A popup will confirm successful validation.
If validation fails, an error message will list any problems you
must resolve before validation can be successful.

 Save Rulepack
1. Choose Save Rulepack from the File menu. The rulepack is
validated before saving. If validation fails, an error message
will list any problems you must resolve before validation can
be successful.
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3 More Support
We hope this document has helped you get started with
SecureAssist. You can submit a support request at
support.codiscope.com. You will also find other manuals, release
notes, system requirements, and more.
Thanks for using Codiscope SecureAssist!
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